#26 2013-07-17 10:56:39

Nyr
Trusted Member
Registered: 2013-03-04
Posts: 335

Re: OpenVPN automated installer

guardianin wrote:

Sure, here you go:
iptables -t nat -A POSTROUTING -s 10.8.0.0/24 -j SNAT --to 10.10.10.192

That looks good.

Please, paste the connection log from the client now that it works.

Offline

#27 2013-07-17 11:01:02

guardianin
Member
Registered: 2013-07-12
Posts: 28

Re: OpenVPN automated installer

Ok, sure. Here it is:

Wed Jul 17 16:28:20 2013 Warning: cannot open --log file: C:\Program Files\OpenVPN\log\client.log: Access is denied.   (errno=5)
Wed Jul 17 16:28:20 2013 OpenVPN 2.3.2 x86_64-w64-mingw32 [SSL (OpenSSL)] [LZO] [PKCS11] [eurephia] [IPv6] built on Jun  3 2013
Wed Jul 17 16:28:20 2013 MANAGEMENT: TCP Socket listening on [AF_INET]127.0.0.1:25340
Wed Jul 17 16:28:20 2013 Need hold release from management interface, waiting...
Wed Jul 17 16:28:21 2013 MANAGEMENT: Client connected from [AF_INET]127.0.0.1:25340
Wed Jul 17 16:28:21 2013 MANAGEMENT: CMD 'state on'
Wed Jul 17 16:28:21 2013 MANAGEMENT: CMD 'log all on'
Wed Jul 17 16:28:21 2013 MANAGEMENT: CMD 'hold off'
Wed Jul 17 16:28:21 2013 MANAGEMENT: CMD 'hold release'
Wed Jul 17 16:28:21 2013 Socket Buffers: R=[65536->65536] S=[65536->65536]
Wed Jul 17 16:28:21 2013 UDPv4 link local: [undef]
Wed Jul 17 16:28:21 2013 UDPv4 link remote: [AF_INET]snipped
Wed Jul 17 16:28:21 2013 MANAGEMENT: >STATE:1374058701,WAIT,,,
Wed Jul 17 16:28:21 2013 MANAGEMENT: >STATE:1374058701,AUTH,,,
Wed Jul 17 16:28:21 2013 TLS: Initial packet from [AF_INET]snipped, sid=c9781111 4b6a86cb
Wed Jul 17 16:28:22 2013 VERIFY OK: depth=1, C=US, ST=CA, L=SanFrancisco, O=Fort-Funston, CN=Fort-Funston CA, [email protected]
Wed Jul 17 16:28:22 2013 VERIFY OK: nsCertType=SERVER
Wed Jul 17 16:28:22 2013 VERIFY OK: depth=0, C=US, ST=CA, L=SanFrancisco, O=Fort-Funston, CN=server, [email protected]
Wed Jul 17 16:28:24 2013 Data Channel Encrypt: Cipher 'BF-CBC' initialized with 128 bit key
Wed Jul 17 16:28:24 2013 Data Channel Encrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
Wed Jul 17 16:28:24 2013 Data Channel Decrypt: Cipher 'BF-CBC' initialized with 128 bit key
Wed Jul 17 16:28:24 2013 Data Channel Decrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
Wed Jul 17 16:28:24 2013 Control Channel: TLSv1, cipher TLSv1/SSLv3 DHE-RSA-AES256-SHA, 1024 bit RSA
Wed Jul 17 16:28:24 2013 [server] Peer Connection Initiated with [AF_INET]snipped
Wed Jul 17 16:28:25 2013 MANAGEMENT: >STATE:1374058705,GET_CONFIG,,,
Wed Jul 17 16:28:26 2013 SENT CONTROL [server]: 'PUSH_REQUEST' (status=1)
Wed Jul 17 16:28:26 2013 PUSH: Received control message: 'PUSH_REPLY,redirect-gateway def1 bypass-dhcp,dhcp-option DNS 129.250.35.250,dhcp-option DNS 74.82.42.42,route 10.8.0.1,topology net30,ping 10,ping-restart 120,ifconfig 10.8.0.6 10.8.0.5'
Wed Jul 17 16:28:26 2013 OPTIONS IMPORT: timers and/or timeouts modified
Wed Jul 17 16:28:26 2013 OPTIONS IMPORT: --ifconfig/up options modified
Wed Jul 17 16:28:26 2013 OPTIONS IMPORT: route options modified
Wed Jul 17 16:28:26 2013 OPTIONS IMPORT: --ip-win32 and/or --dhcp-option options modified
Wed Jul 17 16:28:26 2013 do_ifconfig, tt->ipv6=0, tt->did_ifconfig_ipv6_setup=0
Wed Jul 17 16:28:26 2013 MANAGEMENT: >STATE:1374058706,ASSIGN_IP,,10.8.0.6,
Wed Jul 17 16:28:26 2013 open_tun, tt->ipv6=0
Wed Jul 17 16:28:26 2013 TAP-WIN32 device [Local Area Connection 2] opened: \\.\Global\{FB61B7E1-3154-4B59-9672-2E448D34C05C}.tap
Wed Jul 17 16:28:26 2013 TAP-Windows Driver Version 9.9
Wed Jul 17 16:28:26 2013 Notified TAP-Windows driver to set a DHCP IP/netmask of 10.8.0.6/255.255.255.252 on interface {FB61B7E1-3154-4B59-9672-2E448D34C05C} [DHCP-serv: 10.8.0.5, lease-time: 31536000]
Wed Jul 17 16:28:26 2013 NOTE: FlushIpNetTable failed on interface [49] {FB61B7E1-3154-4B59-9672-2E448D34C05C} (status=5) : Access is denied.

Last edited by guardianin (2013-07-17 11:02:46)

Offline

#28 2013-07-17 11:08:05

Nyr
Trusted Member
Registered: 2013-03-04
Posts: 335

Re: OpenVPN automated installer

guardianin wrote:

Ok, sure. Here it is:

xxx

Looks like that's happening because you are running OpenVPN on Windows Vista/7/8 as a regular user. Try to run OpenVPN as administrator and it should work.

Offline

#29 2013-07-17 11:12:31

guardianin
Member
Registered: 2013-07-12
Posts: 28

Re: OpenVPN automated installer

NICE!!! It's working now, thanks a lot!! I tested with BBC iPlayer, it worked flawlessly! :-D

Just one thing, I queried the IP address, it shows the location as Australia! Any idea why?

Offline

#30 2013-07-17 11:16:54

Backtogeek
Low End Boss
From: ~/
Registered: 2013-02-13
Posts: 3,547
Website

Re: OpenVPN automated installer

I will try to get that sorted haha.

EDIT: the database your using must be out of date, most certainly showing as a UK address here.


http://LittleHappyCloud.net KVM VPS with 1TB Bandwidth for €3.00

Offline

#31 2013-07-17 11:21:58

guardianin
Member
Registered: 2013-07-12
Posts: 28

Re: OpenVPN automated installer

Backtogeek wrote:

the database your using must be out of date, most certainly showing as a UK address here.

Ok, what database is this? Can I update it? If yes, how do I do it?

Offline

#32 2013-07-17 11:32:34

Backtogeek
Low End Boss
From: ~/
Registered: 2013-02-13
Posts: 3,547
Website

Re: OpenVPN automated installer

guardianin wrote:
Backtogeek wrote:

the database your using must be out of date, most certainly showing as a UK address here.

Ok, what database is this? Can I update it? If yes, how do I do it?

No idea what you used to query the IP and no you cannot update it yourself.

The fact that BBCi player works is evidence enough that the IP is now UK registered.


http://LittleHappyCloud.net KVM VPS with 1TB Bandwidth for €3.00

Offline

#33 2013-07-17 11:35:08

guardianin
Member
Registered: 2013-07-12
Posts: 28

Re: OpenVPN automated installer

I just check on www.whatismyipaddress.com, nothing fancy! smile

Ok, as long as it works I am happy!

Offline

#34 2013-07-17 13:27:33

404notfound
Member
Registered: 2013-07-13
Posts: 16

Re: OpenVPN automated installer

What software do I have to use in order to connect to the server client side?

Offline

#35 2013-07-17 13:29:47

guardianin
Member
Registered: 2013-07-12
Posts: 28

Re: OpenVPN automated installer

Offline

#36 2013-07-17 14:12:44

404notfound
Member
Registered: 2013-07-13
Posts: 16

Re: OpenVPN automated installer

And how do I add the .tar.gz file that I get after installation to the client software?

Offline

#37 2013-07-17 14:52:43

Nyr
Trusted Member
Registered: 2013-03-04
Posts: 335

Re: OpenVPN automated installer

404notfound wrote:

And how do I add the .tar.gz file that I get after installation to the client software?

That's a compressed file, you need to extract it. Use Google.

Offline

#38 2013-07-17 15:06:03

404notfound
Member
Registered: 2013-07-13
Posts: 16

Re: OpenVPN automated installer

I was able to do that and renamed the .conf to a .ovpn, but when I use google chrome and go to whatismyip.com, it still shows my own ip.
I am in a country not supported by netflix, and I want to use this for netflix. What do I do?

Offline

#39 2013-07-17 15:46:09

Nyr
Trusted Member
Registered: 2013-03-04
Posts: 335

Re: OpenVPN automated installer

404notfound wrote:

I was able to do that and renamed the .conf to a .ovpn, but when I use google chrome and go to whatismyip.com, it still shows my own ip.
I am in a country not supported by netflix, and I want to use this for netflix. What do I do?

Paste a log.

Offline

#40 2013-07-17 15:54:25

404notfound
Member
Registered: 2013-07-13
Posts: 16

Re: OpenVPN automated installer

Wed Jul 17 20:49:28 2013 Warning: cannot open --log file: C:\Program Files\OpenVPN\log\Asad.log: Access is denied.   (errno=5)
Wed Jul 17 20:49:28 2013 OpenVPN 2.3.2 x86_64-w64-mingw32 [SSL (OpenSSL)] [LZO] [PKCS11] [eurephia] [IPv6] built on Jun  3 2013
Wed Jul 17 20:49:28 2013 MANAGEMENT: TCP Socket listening on [AF_INET]127.0.0.1:25340
Wed Jul 17 20:49:28 2013 Need hold release from management interface, waiting...
Wed Jul 17 20:49:28 2013 MANAGEMENT: Client connected from [AF_INET]127.0.0.1:25340
Wed Jul 17 20:49:28 2013 MANAGEMENT: CMD 'state on'
Wed Jul 17 20:49:28 2013 MANAGEMENT: CMD 'log all on'
Wed Jul 17 20:49:28 2013 MANAGEMENT: CMD 'hold off'
Wed Jul 17 20:49:28 2013 MANAGEMENT: CMD 'hold release'
Wed Jul 17 20:49:28 2013 Socket Buffers: R=[65536->65536] S=[65536->65536]
Wed Jul 17 20:49:28 2013 UDPv4 link local: [undef]
Wed Jul 17 20:49:28 2013 UDPv4 link remote: [AF_INET]hidden:19502
Wed Jul 17 20:49:28 2013 MANAGEMENT: >STATE:1374074368,WAIT,,,
Wed Jul 17 20:49:33 2013 MANAGEMENT: >STATE:1374074373,AUTH,,,
Wed Jul 17 20:49:33 2013 TLS: Initial packet from [AF_INET]hidden:19502, sid=194c2cc6 c17d4825
Wed Jul 17 20:49:34 2013 VERIFY OK: depth=1, C=US, ST=CA, L=SanFrancisco, O=Fort-Funston, CN=Fort-Funston CA, [email protected]
Wed Jul 17 20:49:34 2013 VERIFY OK: nsCertType=SERVER
Wed Jul 17 20:49:34 2013 VERIFY OK: depth=0, C=US, ST=CA, L=SanFrancisco, O=Fort-Funston, CN=server, [email protected]
Wed Jul 17 20:49:38 2013 Data Channel Encrypt: Cipher 'BF-CBC' initialized with 128 bit key
Wed Jul 17 20:49:38 2013 Data Channel Encrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
Wed Jul 17 20:49:38 2013 Data Channel Decrypt: Cipher 'BF-CBC' initialized with 128 bit key
Wed Jul 17 20:49:38 2013 Data Channel Decrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
Wed Jul 17 20:49:38 2013 Control Channel: TLSv1, cipher TLSv1/SSLv3 DHE-RSA-AES256-SHA, 1024 bit RSA
Wed Jul 17 20:49:38 2013 [server] Peer Connection Initiated with [AF_INET]hidden:19502
Wed Jul 17 20:49:39 2013 MANAGEMENT: >STATE:1374074379,GET_CONFIG,,,
Wed Jul 17 20:49:41 2013 SENT CONTROL [server]: 'PUSH_REQUEST' (status=1)
Wed Jul 17 20:49:41 2013 PUSH: Received control message: 'PUSH_REPLY,redirect-gateway def1 bypass-dhcp,dhcp-option DNS 129.250.35.250,dhcp-option DNS 74.82.42.42,route 10.8.0.1,topology net30,ping 10,ping-restart 120,ifconfig 10.8.0.6 10.8.0.5'
Wed Jul 17 20:49:41 2013 OPTIONS IMPORT: timers and/or timeouts modified
Wed Jul 17 20:49:41 2013 OPTIONS IMPORT: --ifconfig/up options modified
Wed Jul 17 20:49:41 2013 OPTIONS IMPORT: route options modified
Wed Jul 17 20:49:41 2013 OPTIONS IMPORT: --ip-win32 and/or --dhcp-option options modified
Wed Jul 17 20:49:41 2013 do_ifconfig, tt->ipv6=0, tt->did_ifconfig_ipv6_setup=0
Wed Jul 17 20:49:41 2013 MANAGEMENT: >STATE:1374074381,ASSIGN_IP,,10.8.0.6,
Wed Jul 17 20:49:41 2013 open_tun, tt->ipv6=0
Wed Jul 17 20:49:41 2013 TAP-WIN32 device [Local Area Connection] opened: \\.\Global\{139A69BA-991F-45D0-89A0-1009D146AE44}.tap
Wed Jul 17 20:49:41 2013 TAP-Windows Driver Version 9.9
Wed Jul 17 20:49:41 2013 Notified TAP-Windows driver to set a DHCP IP/netmask of 10.8.0.6/255.255.255.252 on interface {139A69BA-991F-45D0-89A0-1009D146AE44} [DHCP-serv: 10.8.0.5, lease-time: 31536000]
Wed Jul 17 20:49:41 2013 NOTE: FlushIpNetTable failed on interface [32] {139A69BA-991F-45D0-89A0-1009D146AE44} (status=5) : Access is denied. 
Wed Jul 17 20:49:46 2013 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down
Wed Jul 17 20:49:46 2013 Route: Waiting for TUN/TAP interface to come up...
Wed Jul 17 20:49:52 2013 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down
Wed Jul 17 20:49:52 2013 Route: Waiting for TUN/TAP interface to come up...
Wed Jul 17 20:49:53 2013 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down
Wed Jul 17 20:49:53 2013 Route: Waiting for TUN/TAP interface to come up...
Wed Jul 17 20:49:54 2013 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down
Wed Jul 17 20:49:54 2013 Route: Waiting for TUN/TAP interface to come up...
Wed Jul 17 20:49:55 2013 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down
Wed Jul 17 20:49:55 2013 Route: Waiting for TUN/TAP interface to come up...
Wed Jul 17 20:49:56 2013 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down
Wed Jul 17 20:49:56 2013 Route: Waiting for TUN/TAP interface to come up...
Wed Jul 17 20:49:58 2013 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down
Wed Jul 17 20:49:58 2013 Route: Waiting for TUN/TAP interface to come up...
Wed Jul 17 20:49:59 2013 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down
Wed Jul 17 20:49:59 2013 Route: Waiting for TUN/TAP interface to come up...
Wed Jul 17 20:50:00 2013 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down
Wed Jul 17 20:50:00 2013 Route: Waiting for TUN/TAP interface to come up...
Wed Jul 17 20:50:01 2013 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down
Wed Jul 17 20:50:01 2013 Route: Waiting for TUN/TAP interface to come up...
Wed Jul 17 20:50:02 2013 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down
Wed Jul 17 20:50:02 2013 Route: Waiting for TUN/TAP interface to come up...
Wed Jul 17 20:50:03 2013 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down
Wed Jul 17 20:50:03 2013 Route: Waiting for TUN/TAP interface to come up...
Wed Jul 17 20:50:04 2013 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down
Wed Jul 17 20:50:04 2013 Route: Waiting for TUN/TAP interface to come up...
Wed Jul 17 20:50:05 2013 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down
Wed Jul 17 20:50:05 2013 Route: Waiting for TUN/TAP interface to come up...
Wed Jul 17 20:50:06 2013 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down
Wed Jul 17 20:50:06 2013 Route: Waiting for TUN/TAP interface to come up...
Wed Jul 17 20:50:07 2013 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down
Wed Jul 17 20:50:07 2013 Route: Waiting for TUN/TAP interface to come up...
Wed Jul 17 20:50:08 2013 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down
Wed Jul 17 20:50:08 2013 Route: Waiting for TUN/TAP interface to come up...
Wed Jul 17 20:50:10 2013 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down
Wed Jul 17 20:50:10 2013 Route: Waiting for TUN/TAP interface to come up...
Wed Jul 17 20:50:11 2013 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down
Wed Jul 17 20:50:11 2013 Route: Waiting for TUN/TAP interface to come up...
Wed Jul 17 20:50:12 2013 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down
Wed Jul 17 20:50:12 2013 Route: Waiting for TUN/TAP interface to come up...
Wed Jul 17 20:50:13 2013 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down
Wed Jul 17 20:50:13 2013 Route: Waiting for TUN/TAP interface to come up...
Wed Jul 17 20:50:14 2013 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down
Wed Jul 17 20:50:14 2013 Route: Waiting for TUN/TAP interface to come up...
Wed Jul 17 20:50:16 2013 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down
Wed Jul 17 20:50:16 2013 C:\Windows\system32\route.exe ADD hidden MASK 255.255.255.255 192.168.1.1
Wed Jul 17 20:50:16 2013 ROUTE: route addition failed using CreateIpForwardEntry: Access is denied.   [status=5 if_index=14]
Wed Jul 17 20:50:16 2013 Route addition via IPAPI failed [adaptive]
Wed Jul 17 20:50:16 2013 Route addition fallback to route.exe
Wed Jul 17 20:50:16 2013 env_block: add PATH=C:\Windows\System32;C:\WINDOWS;C:\WINDOWS\System32\Wbem
Wed Jul 17 20:50:17 2013 ERROR: Windows route add command failed [adaptive]: returned error code 1
Wed Jul 17 20:50:17 2013 C:\Windows\system32\route.exe ADD 192.168.1.1 MASK 255.255.255.255 192.168.1.1 IF 14
Wed Jul 17 20:50:17 2013 ROUTE: route addition failed using CreateIpForwardEntry: Access is denied.   [status=5 if_index=14]
Wed Jul 17 20:50:17 2013 Route addition via IPAPI failed [adaptive]
Wed Jul 17 20:50:17 2013 Route addition fallback to route.exe
Wed Jul 17 20:50:17 2013 env_block: add PATH=C:\Windows\System32;C:\WINDOWS;C:\WINDOWS\System32\Wbem
Wed Jul 17 20:50:17 2013 ERROR: Windows route add command failed [adaptive]: returned error code 1
Wed Jul 17 20:50:17 2013 C:\Windows\system32\route.exe ADD 0.0.0.0 MASK 128.0.0.0 10.8.0.5
Wed Jul 17 20:50:17 2013 Warning: route gateway is not reachable on any active network adapters: 10.8.0.5
Wed Jul 17 20:50:17 2013 Route addition via IPAPI failed [adaptive]
Wed Jul 17 20:50:17 2013 Route addition fallback to route.exe
Wed Jul 17 20:50:17 2013 env_block: add PATH=C:\Windows\System32;C:\WINDOWS;C:\WINDOWS\System32\Wbem
Wed Jul 17 20:50:17 2013 ERROR: Windows route add command failed [adaptive]: returned error code 1
Wed Jul 17 20:50:17 2013 C:\Windows\system32\route.exe ADD 128.0.0.0 MASK 128.0.0.0 10.8.0.5
Wed Jul 17 20:50:17 2013 Warning: route gateway is not reachable on any active network adapters: 10.8.0.5
Wed Jul 17 20:50:17 2013 Route addition via IPAPI failed [adaptive]
Wed Jul 17 20:50:17 2013 Route addition fallback to route.exe
Wed Jul 17 20:50:17 2013 env_block: add PATH=C:\Windows\System32;C:\WINDOWS;C:\WINDOWS\System32\Wbem
Wed Jul 17 20:50:17 2013 ERROR: Windows route add command failed [adaptive]: returned error code 1
Wed Jul 17 20:50:17 2013 MANAGEMENT: >STATE:1374074417,ADD_ROUTES,,,
Wed Jul 17 20:50:17 2013 C:\Windows\system32\route.exe ADD 10.8.0.1 MASK 255.255.255.255 10.8.0.5
Wed Jul 17 20:50:17 2013 Warning: route gateway is not reachable on any active network adapters: 10.8.0.5
Wed Jul 17 20:50:17 2013 Route addition via IPAPI failed [adaptive]
Wed Jul 17 20:50:17 2013 Route addition fallback to route.exe
Wed Jul 17 20:50:17 2013 env_block: add PATH=C:\Windows\System32;C:\WINDOWS;C:\WINDOWS\System32\Wbem
Wed Jul 17 20:50:17 2013 ERROR: Windows route add command failed [adaptive]: returned error code 1
Wed Jul 17 20:50:17 2013 SYSTEM ROUTING TABLE
Wed Jul 17 20:50:17 2013 0.0.0.0 0.0.0.0 192.168.1.1 p=0 i=14 t=4 pr=3 a=5806 h=0 m=25/0/0/0/0
Wed Jul 17 20:50:17 2013 127.0.0.0 255.0.0.0 127.0.0.1 p=0 i=1 t=3 pr=2 a=5845 h=0 m=306/0/0/0/0
Wed Jul 17 20:50:17 2013 127.0.0.1 255.255.255.255 127.0.0.1 p=0 i=1 t=3 pr=2 a=5845 h=0 m=306/0/0/0/0
Wed Jul 17 20:50:17 2013 127.255.255.255 255.255.255.255 127.0.0.1 p=0 i=1 t=3 pr=2 a=5845 h=0 m=306/0/0/0/0
Wed Jul 17 20:50:17 2013 169.254.0.0 255.255.0.0 169.254.232.184 p=0 i=32 t=3 pr=2 a=32 h=0 m=286/0/0/0/0
Wed Jul 17 20:50:17 2013 169.254.232.184 255.255.255.255 169.254.232.184 p=0 i=32 t=3 pr=2 a=32 h=0 m=286/0/0/0/0
Wed Jul 17 20:50:17 2013 169.254.255.255 255.255.255.255 169.254.232.184 p=0 i=32 t=3 pr=2 a=32 h=0 m=286/0/0/0/0
Wed Jul 17 20:50:17 2013 192.168.1.0 255.255.255.0 192.168.1.5 p=0 i=14 t=3 pr=2 a=5806 h=0 m=281/0/0/0/0
Wed Jul 17 20:50:17 2013 192.168.1.5 255.255.255.255 192.168.1.5 p=0 i=14 t=3 pr=2 a=5806 h=0 m=281/0/0/0/0
Wed Jul 17 20:50:17 2013 192.168.1.255 255.255.255.255 192.168.1.5 p=0 i=14 t=3 pr=2 a=5806 h=0 m=281/0/0/0/0
Wed Jul 17 20:50:17 2013 224.0.0.0 240.0.0.0 127.0.0.1 p=0 i=1 t=3 pr=2 a=5845 h=0 m=306/0/0/0/0
Wed Jul 17 20:50:17 2013 224.0.0.0 240.0.0.0 192.168.1.5 p=0 i=14 t=3 pr=2 a=5821 h=0 m=281/0/0/0/0
Wed Jul 17 20:50:17 2013 224.0.0.0 240.0.0.0 169.254.232.184 p=0 i=32 t=3 pr=2 a=231 h=0 m=286/0/0/0/0
Wed Jul 17 20:50:17 2013 255.255.255.255 255.255.255.255 127.0.0.1 p=0 i=1 t=3 pr=2 a=5845 h=0 m=306/0/0/0/0
Wed Jul 17 20:50:17 2013 255.255.255.255 255.255.255.255 192.168.1.5 p=0 i=14 t=3 pr=2 a=5821 h=0 m=281/0/0/0/0
Wed Jul 17 20:50:17 2013 255.255.255.255 255.255.255.255 169.254.232.184 p=0 i=32 t=3 pr=2 a=231 h=0 m=286/0/0/0/0
Wed Jul 17 20:50:17 2013 SYSTEM ADAPTER LIST
Wed Jul 17 20:50:17 2013 TAP-Windows Adapter V9
Wed Jul 17 20:50:17 2013   Index = 32
Wed Jul 17 20:50:17 2013   GUID = {139A69BA-991F-45D0-89A0-1009D146AE44}
Wed Jul 17 20:50:17 2013   IP = 169.254.232.184/255.255.0.0
Wed Jul 17 20:50:17 2013   MAC = 00:ff:13:9a:69:ba
Wed Jul 17 20:50:17 2013   GATEWAY = 0.0.0.0/255.255.255.255
Wed Jul 17 20:50:17 2013   DHCP SERV = 0.0.0.0/255.255.255.255
Wed Jul 17 20:50:17 2013   DHCP LEASE OBTAINED = Wed Jul 17 20:50:17 2013
Wed Jul 17 20:50:17 2013   DHCP LEASE EXPIRES  = Wed Jul 17 20:50:17 2013
Wed Jul 17 20:50:17 2013   DNS SERV = 
Wed Jul 17 20:50:17 2013 Spotflux Virtual Network Device Driver
Wed Jul 17 20:50:17 2013   Index = 44
Wed Jul 17 20:50:17 2013   GUID = {DE60233B-797E-4FE2-A64A-E8AD7C742B77}
Wed Jul 17 20:50:17 2013   IP = 0.0.0.0/0.0.0.0
Wed Jul 17 20:50:17 2013   MAC = 00:ff:de:60:23:3b
Wed Jul 17 20:50:17 2013   GATEWAY = 0.0.0.0/255.255.255.255
Wed Jul 17 20:50:17 2013   DHCP SERV = 
Wed Jul 17 20:50:17 2013   DHCP LEASE OBTAINED = Wed Jul 17 20:50:17 2013
Wed Jul 17 20:50:17 2013   DHCP LEASE EXPIRES  = Wed Jul 17 20:50:17 2013
Wed Jul 17 20:50:17 2013   DNS SERV = 
Wed Jul 17 20:50:17 2013 Microsoft Hosted Network Virtual Adapter
Wed Jul 17 20:50:17 2013   Index = 37
Wed Jul 17 20:50:17 2013   GUID = {D19DA320-822F-45FC-9E86-C53DBB42823A}
Wed Jul 17 20:50:17 2013   IP = 0.0.0.0/0.0.0.0
Wed Jul 17 20:50:17 2013   MAC = 5e:b7:0d:c8:1d:83
Wed Jul 17 20:50:17 2013   GATEWAY = 0.0.0.0/255.255.255.255
Wed Jul 17 20:50:17 2013   DHCP SERV = 
Wed Jul 17 20:50:17 2013   DHCP LEASE OBTAINED = Wed Jul 17 20:50:17 2013
Wed Jul 17 20:50:17 2013   DHCP LEASE EXPIRES  = Wed Jul 17 20:50:17 2013
Wed Jul 17 20:50:17 2013   DNS SERV = 
Wed Jul 17 20:50:17 2013 Microsoft Wi-Fi Direct Virtual Adapter
Wed Jul 17 20:50:17 2013   Index = 36
Wed Jul 17 20:50:17 2013   GUID = {988762FF-8B4A-4D9D-9DB2-563C443FB52E}
Wed Jul 17 20:50:17 2013   IP = 0.0.0.0/0.0.0.0
Wed Jul 17 20:50:17 2013   MAC = 1e:b7:0d:c8:1d:83
Wed Jul 17 20:50:17 2013   GATEWAY = 0.0.0.0/255.255.255.255
Wed Jul 17 20:50:17 2013   DHCP SERV = 
Wed Jul 17 20:50:17 2013   DHCP LEASE OBTAINED = Wed Jul 17 20:50:17 2013
Wed Jul 17 20:50:17 2013   DHCP LEASE EXPIRES  = Wed Jul 17 20:50:17 2013
Wed Jul 17 20:50:17 2013   DNS SERV = 
Wed Jul 17 20:50:17 2013 Qualcomm Atheros AR5BWB222 Wireless Network Adapter
Wed Jul 17 20:50:17 2013   Index = 14
Wed Jul 17 20:50:17 2013   GUID = {1C5FF322-BC0E-4E6E-AAC7-55C945BFC1B8}
Wed Jul 17 20:50:17 2013   IP = 192.168.1.5/255.255.255.0
Wed Jul 17 20:50:17 2013   MAC = 9c:b7:0d:c8:1d:83
Wed Jul 17 20:50:17 2013   GATEWAY = 192.168.1.1/255.255.255.255
Wed Jul 17 20:50:17 2013   DHCP SERV = 192.168.1.1/255.255.255.255
Wed Jul 17 20:50:17 2013   DHCP LEASE OBTAINED = Wed Jul 17 19:13:33 2013
Wed Jul 17 20:50:17 2013   DHCP LEASE EXPIRES  = Thu Jul 18 19:13:33 2013
Wed Jul 17 20:50:17 2013   DNS SERV = 192.168.1.1/255.255.255.255 218.248.241.6/255.255.255.255
Wed Jul 17 20:50:17 2013 Atheros AR8151 PCI-E Gigabit Ethernet Controller (NDIS 6.20)
Wed Jul 17 20:50:17 2013   Index = 13
Wed Jul 17 20:50:17 2013   GUID = {6B6A8A01-76A1-4413-9D26-C5B73486C86F}
Wed Jul 17 20:50:17 2013   IP = 0.0.0.0/0.0.0.0
Wed Jul 17 20:50:17 2013   MAC = 50:e5:49:ef:79:ab
Wed Jul 17 20:50:17 2013   GATEWAY = 0.0.0.0/255.255.255.255
Wed Jul 17 20:50:17 2013   DHCP SERV = 
Wed Jul 17 20:50:17 2013   DHCP LEASE OBTAINED = Wed Jul 17 20:50:17 2013
Wed Jul 17 20:50:17 2013   DHCP LEASE EXPIRES  = Wed Jul 17 20:50:17 2013
Wed Jul 17 20:50:17 2013   DNS SERV = 
Wed Jul 17 20:50:17 2013 Intel(R) 82579V Gigabit Network Connection
Wed Jul 17 20:50:17 2013   Index = 12
Wed Jul 17 20:50:17 2013   GUID = {E25C2043-B84C-41D5-945B-BFD17709A04C}
Wed Jul 17 20:50:17 2013   IP = 0.0.0.0/0.0.0.0
Wed Jul 17 20:50:17 2013   MAC = 50:e5:49:ef:79:a9
Wed Jul 17 20:50:17 2013   GATEWAY = 0.0.0.0/255.255.255.255
Wed Jul 17 20:50:17 2013   DHCP SERV = 
Wed Jul 17 20:50:17 2013   DHCP LEASE OBTAINED = Wed Jul 17 20:50:17 2013
Wed Jul 17 20:50:17 2013   DHCP LEASE EXPIRES  = Wed Jul 17 20:50:17 2013
Wed Jul 17 20:50:17 2013   DNS SERV = 
Wed Jul 17 20:50:17 2013 Initialization Sequence Completed With Errors ( see http://openvpn.net/faq.html#dhcpclientserv )
Wed Jul 17 20:50:17 2013 MANAGEMENT: >STATE:1374074417,CONNECTED,ERROR,10.8.0.6,hidden

Last edited by 404notfound (2013-07-17 16:02:00)

Offline

#41 2013-07-17 15:59:03

404notfound
Member
Registered: 2013-07-13
Posts: 16

Re: OpenVPN automated installer

I run it as admin and it works now. Its kinda slow though, what would cause that?

Offline

#42 2013-07-17 15:59:13

Nyr
Trusted Member
Registered: 2013-03-04
Posts: 335

Re: OpenVPN automated installer

404notfound wrote:

Wed Jul 17 20:49:28 2013 Warning: cannot open --log file: C:\Program Files\OpenVPN\log\Asad.log: Access is denied.   (errno=5)
...

I don't think it would be so difficult to read the post above yours which had exactly the same problem. Also, remove the public server IP from the log.

Last edited by Nyr (2013-07-17 15:59:24)

Offline

#43 2013-07-17 16:01:50

Nyr
Trusted Member
Registered: 2013-03-04
Posts: 335

Re: OpenVPN automated installer

404notfound wrote:

I run it as admin and it works now. Its kinda slow though, what would cause that?

Oh, just submitted my post as you sent yours.

If it's slow, probably your connection to the server isn't good. That happens if you are on another continent or just if the peering within both ISPs sucks.

Probably, not much you can do.

Offline

#44 2013-07-17 16:03:38

404notfound
Member
Registered: 2013-07-13
Posts: 16

Re: OpenVPN automated installer

Ok, thanks. Looks like I will have to do with it anyways.

Offline

#45 2013-07-18 14:46:42

Nyr
Trusted Member
Registered: 2013-03-04
Posts: 335

Re: OpenVPN automated installer

Ray wrote:

Define slow? Openvpn slow due to it running in userspace or really slow? I find that a 30mbit adsl line will
get around one eigth of that on scp and http downstream from .uk. When you´re vpn'ed and all traffic your box
generates goes over that one 128/64 Mb vps-vpn it might be less methinks. But as said that´s on a .uk
vps.

RAM or CPU usage aren't a problem with OpenVPN on that kind of domestic connections. Simply, the connection to the server might not be the best from his ISP.

Last edited by Nyr (2013-07-18 14:47:06)

Offline

#46 2013-07-18 15:50:02

Nyr
Trusted Member
Registered: 2013-03-04
Posts: 335

Re: OpenVPN automated installer

Ray wrote:

Well, as I´m not able to saturate 30mbit from a 100mbit vps (I know others are using it at
the same time) I just wonder what he considers slow. As openvpn is still userspace and
generates more overhead he might be getting around the same figure or less. It all depends
on what you expect and you cannot expect the same speeds as from your standard connection.

It still is a 100mbit connected box and with ten users vpn'ing it gives 10mbit each and with
10 more users go do the math wink When you want speed you need to get your own box with
a 100mbit uplink and even those are routed throug gigabit switches with more than ten
boxes on them. It´s a shared world after all smile

I am pretty sure the node isn't using 100 mbps constantly, not even anything near that. You can't assume ten users would be using 10 mbps constantly.

Most probably it's simply the quality of the connection. For example, I can max out my connection when downloading from European and most North American servers but not from Asia. And the same applies for Asian users connecting to European or East Coast servers.

That applies for bandwidth quality too. Is not the same on a pure Level 3 connection than a Cogent or HE one.

You would be able to use your full 30mbit connection (assuming you really get that from your DSL) if you were downloading from servers with a good connection to your ISP.

Offline

#47 2013-07-19 01:18:54

404notfound
Member
Registered: 2013-07-13
Posts: 16

Re: OpenVPN automated installer

Well, I installed it on another vps of mine, not from here, and it has a dedicated ipv4, and it works much much faster.
Maybe its the NATed connection, or the location of the VPS. This vps of mine is in the US.
It might just be the latency, as I dont see any noticeable lag in my USA vps. Or that the connection on my lowendspirit box is saturated or slow.
Edit : I just pinged Google while connected to my US VPN, and I get a 38 ms average ping. Without the VPN, its 300+.

Last edited by 404notfound (2013-07-19 01:30:39)

Offline

#48 2013-07-19 06:26:44

Backtogeek
Low End Boss
From: ~/
Registered: 2013-02-13
Posts: 3,547
Website

Re: OpenVPN automated installer

If you are comparing speeds and the only metrics you are throwing in for analysis is the country you should probably just stop using the internet before you upset it. smile

I don't buy a VPS in Vietnam while in the UK and expect to be able to get 100mbit on my 20mbit home grade dsl line, sadly some people do smile

Anyway if you would like to discuss the finer points of how the internet works could you guys open another thread as this is is an installer and help guide really smile


http://LittleHappyCloud.net KVM VPS with 1TB Bandwidth for €3.00

Offline

#49 2013-12-08 04:55:05

Nyr
Trusted Member
Registered: 2013-03-04
Posts: 335

Re: OpenVPN automated installer

@sonic no need to spam me via the forum and email too.

No, you can't use this script for that. You can probably look at Google for instructions on what you want, or if you aren't capable of setting it up, I can offer my services as a systems and network administrator too.

Offline

#50 2013-12-08 05:12:15

Nyr
Trusted Member
Registered: 2013-03-04
Posts: 335

Re: OpenVPN automated installer

Third search result on Bing:
http://serverfault.com/questions/71310/ … -addresses

Just change that to a /32 if that's what you want.

Don't worry about payment, I don't currently charge anything for linking to serverfault.

Offline

Board footer