#1 2018-01-04 18:15:12

Justanothergnat
Trusted Member
Registered: 2018-01-04
Posts: 4

[InceptionHosting PHX] Don't think I am getting ports forwarded

So I finally got some time to play with the VPS I got from black friday all of them work great except for Phoenix.

I am trying to get shadowsocks to listen on port 220.  My IP on phoenix ends in .2, I ssh in with port 221.  If my understanding is correct, like with the rest of my VPS, I get 201-220 to use for port forwards on IPv4.

<image removed, contains external ip>

From the screenshot you can see I have the service running, and then attempt an nmap scan just with the 20 ports assigned to me.  Netstat shows that it is listening on port 220, but nmap does not see it at the external IP.

I am at a loss here, I have tried different 2xx ports still no luck.

Offline

#2 2018-01-04 19:43:18

mikho
Low End Mod
From: Hell and gore == Sweden
Registered: 2013-03-02
Posts: 1,383
Website

Re: [InceptionHosting PHX] Don't think I am getting ports forwarded

Do you have a firewall running?

Offline

#3 2018-01-04 19:43:57

mikho
Low End Mod
From: Hell and gore == Sweden
Registered: 2013-03-02
Posts: 1,383
Website

Re: [InceptionHosting PHX] Don't think I am getting ports forwarded

And you should never run stuff as root ....

Offline

#4 2018-01-04 20:42:08

Backtogeek
Low End Boss
From: ~/
Registered: 2013-02-13
Posts: 3,604
Website

Re: [InceptionHosting PHX] Don't think I am getting ports forwarded

]# telnet 192.168.20.2 220
Trying 192.168.20.2...
telnet: connect to address 192.168.20.2: Connection refused

That's from the node (bypass forwarding) seems you have it blocked, can you telnet to the port locally on the VPS?


http://LittleHappyCloud.net KVM VPS with 1TB Bandwidth for €3.00

Online

#5 2018-01-04 22:37:40

Justanothergnat
Trusted Member
Registered: 2018-01-04
Posts: 4

Re: [InceptionHosting PHX] Don't think I am getting ports forwarded

@mikho no I am not running a firewall, and I understand it should not be ran as root, but at the time of the screenshot I was just testing it.

@Backtogeek, it was running in the foreground and I closed it, I will start it again.  I did not think to try telnetting locally... not sure what that would prove?

telnetting locally appears to work I guess?
We0jgu1.png

Also netstat
jRLaqQz.png

Last edited by Justanothergnat (2018-01-04 22:40:55)

Offline

#6 2018-01-05 07:02:51

Backtogeek
Low End Boss
From: ~/
Registered: 2013-02-13
Posts: 3,604
Website

Re: [InceptionHosting PHX] Don't think I am getting ports forwarded

It just proves that the service is actively accepting connections, I will check it again when I am not on the iPad.


http://LittleHappyCloud.net KVM VPS with 1TB Bandwidth for €3.00

Online

#7 2018-01-05 10:26:18

Backtogeek
Low End Boss
From: ~/
Registered: 2013-02-13
Posts: 3,604
Website

Re: [InceptionHosting PHX] Don't think I am getting ports forwarded

I think it may be something to do with low/reserved ports, I have changed your IP to end in .33


http://LittleHappyCloud.net KVM VPS with 1TB Bandwidth for €3.00

Online

#8 2018-01-05 22:15:10

Justanothergnat
Trusted Member
Registered: 2018-01-04
Posts: 4

Re: [InceptionHosting PHX] Don't think I am getting ports forwarded

That must have been it, thanks all set.

Offline

Board footer