#1 2018-03-28 11:35:20

kiwiblush
Trusted Member
Registered: 2018-03-28
Posts: 4

[MrVM] Domain forwarding

Hi, please excuse me if I'm asking a very silly question. I have a NAT server at Bulgaria, and I've been trying to point my domain to the server but I can't seem to get it to work.

Cloudflare configuration:

Record type: A
Name: abc.tld
Value: External IP
TTL: Automatic

Record type: CNAME
Name: www
Value: abc.tld
TTL: Automatic

-----

Domain forwarding configuration:

Protocol: HTTP
Source Domain/IP: abc.tld
Source Port: 80
Destination IP: IPv4 address
Destination Port: 80

-----

Nginx configuration:

server {
    listen 80 default_server;
    listen [::]:80 default_server;
    root /srv/www/abc.tld/html;
    index index.html index.htm;
    server_name abc.tld www.abc.tld;

    location ~ /\. {
        deny all;
        access_log off;
        log_not_found off;
    }

    location / {
        try_files $uri $uri/ =404;
    }
}

-----

I have also tried using Cloudflare to proxy IPv6 (record AAAA) but failed as well. (How, I don't know...) Would greatly appreciate any help. Thank you!

Offline

#2 2018-03-28 12:38:29

mikho
Low End Mod
From: Hell and gore == Sweden
Registered: 2013-03-02
Posts: 1,519
Website

Re: [MrVM] Domain forwarding

Whats the last part of your IP?

Online

#3 2018-03-28 12:41:43

kiwiblush
Trusted Member
Registered: 2018-03-28
Posts: 4

Re: [MrVM] Domain forwarding

Hi, it's 247.

Last edited by kiwiblush (2018-03-28 12:57:24)

Offline

#4 2018-03-28 15:29:51

mikho
Low End Mod
From: Hell and gore == Sweden
Registered: 2013-03-02
Posts: 1,519
Website

Re: [MrVM] Domain forwarding

I’ll have a look after I get back from the store.

Online

#5 2018-03-28 20:28:02

mikho
Low End Mod
From: Hell and gore == Sweden
Registered: 2013-03-02
Posts: 1,519
Website

Re: [MrVM] Domain forwarding

got it.

it's working now.

Online

#6 2018-03-29 07:11:03

kiwiblush
Trusted Member
Registered: 2018-03-28
Posts: 4

Re: [MrVM] Domain forwarding

Thank you!!

Edit: I've installed Letsencrypt certs and added 443 in the Domain Forwarding section. Do I have to do anything else or am I doing something wrong? I'm getting a "secure connection failed" error now. Sorry for the trouble!

Last edited by kiwiblush (2018-03-29 07:45:22)

Offline

#7 2018-03-29 08:27:46

mikho
Low End Mod
From: Hell and gore == Sweden
Registered: 2013-03-02
Posts: 1,519
Website

Re: [MrVM] Domain forwarding

Nothing else should be needed.
Are you serving content from both http and https?

Online

#8 2018-03-29 08:40:22

kiwiblush
Trusted Member
Registered: 2018-03-28
Posts: 4

Re: [MrVM] Domain forwarding

I'd wanted to serve from https originally, but I couldn't get http to work before I got around to installing the certs; I thought it was a configuration mistake from my end.

Offline

Board footer

Powered by FluxBB